OpenMAMA QPID Bridge issues


Guy <guy.tal@...>
 


Hello,

I'm starting an evaluation of OpenMama (OpenMAMA 2.3.0 branch) over Qpid. I have some questions about what is covered and what tools are available. I have also had some problems with building, which are described below.

Once the build is complete, I will want to test running a Mama publisher and then subscribe to the data using mamalistenc and the Qpid bridge. Is there any documentation in the system showing me how to do this?

Finally I then want to try and get the OpenMama market data replay tools running over Qpid. Has this setup been tested ? Will it work ?


Windows Build problems.

I am seeing the following problems:
The errors I get from SCONS are:
  1. ERROR::   shared_dir None does not exist 
  2. scons: *** [D:\omama230\dynamic\common\c_cpp\src\c\libwombatcommonmd.dll] Error 1104

Details of the build in Windows problem are attached here. 
The command line for scons I ran is:
>scons middleware=qpid product=mama qpid_home=D:\proton blddir=d:\omama230 buildtype=dynamic verbose=yes
Where:
qpid_home=D:\proton - the proton tree is manually fixed by me and may not be correct
D:\PROTON
+---proton
¦   +---examples
¦   ¦   +---messenger
¦   ¦       +---pncompat
¦   +---include
¦       +---proton        <- has only version.h + all include folder I collected from 
|
+---Release               <- has the qpid-proton.dll and qpid-proton.lib
|                         <- do you expect the folder to be lib and lib64 (as in linux)?
|                         <- or do you expect a folder tree to be /architecture/configuration
|                         <- like x64/Release ?
+---share
    +---java
    +---proton-0.6


Linux Build Problems

In a clean Linux workstation I tried to follow the instructions I found in http://wiki.openmama.org/index.php/Quick_start_guide
Running  sudo yum install openmama-2.3.0-1.el6_.x86_64.rpm yielded this result:
Error: Package: openmama-2.3.0-1.el6.x86_64 (/openmama-2.3.0-1.el6_.x86_64)
           Requires: qpid-proton
Error: Package: openmama-2.3.0-1.el6.x86_64 (/openmama-2.3.0-1.el6_.x86_64)
           Requires: libqpid-proton.so.1()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

However trying to build OpenMAMA 2.3.0 against the proton 0.25 also failed.

The only working combination was building the feature-qpid-bridge branch and building the proton 0.27 (cloned from svn).

Regards,
Guy

Join Openmama-dev@lists.openmama.org to automatically receive all group messages.