Re: OpenMAMA QPID Bridge issues


Guy <guy.tal@...>
 

Hello Damian,
Thanks for the fast reply.

Linux Build

  • I expected the capturereplayc to be under /opt/openmama/bin, maybe I'm wrong here? Anyway everything I said is related to the feature-qpid-bridge branch which maybe is different than the OpenMAMA-2.3.0 branch. In Linux the only combination for me to build & run was: feature-qpid-bridge and proton from svn version 0.27.
  • I re-cloned the branch OpenMAMA-2.3.0 and rebuilt the whole project with scons, see OpenMAMA230.linux.scons.result.txt attachment for the command line and output in that file. I get there an error with event.h
  • Later on I retried to build using autotools (configure/make) as see the attached file OpenMAMA230.linux.make.result.txt for that. The same error with event.h repeats itself.
    • Configure command was: ./configure --proton-path=/home/mama/proton

Windows Build

  • An output file from running scons on Windows is attached here too, see  openmama230_fail.txt for the result.
  • I tried the verbose option.

Linux Install (Package)

  • The distribution I'm working with is CentOS 6.4 64bit on 2 machines. One machine is a minimal install. It has EPEL repository for all the extra packages needed though. I'll discuss that machine.
I was using the second version of the pack openmama-2.3.0-2.el6_.x86_64.rpm for the install.

The problem was exactly a missing dependency as you described and also a library version issue. Since I couldn't find the qpid-proton package with yum I decided download both binaries and devel packages directly:
  1. wget http://mirrors.neterra.net/epel/6/x86_64/qpid-proton-c-devel-0.5-2.el6.x86_64.rpm
  2. wget http://mirrors.neterra.net/epel/6/x86_64/qpid-proton-c-0.5-2.el6.x86_64.rpm

None of them actually fix the problem and I still get an error.
Please pay attention that all I can get from the repository is newer version of qpid-proton (see red color):
Error: Package: openmama-2.3.0-1.el6.x86_64 (/openmama-2.3.0-1.el6_.x86_64)
           Requires: libqpid-proton.so.1()(64bit)

From what I've listed from rpm I realize that it is a version issue:
/usr/bin/proton
/usr/bin/proton-dump
/usr/lib64/libqpid-proton.so.2                  <- too new? no non-versioned symbolic link?
/usr/lib64/libqpid-proton.so.2.0.0

trying to find an old package like:
qpid-proton-c-devel-0.5-1.el6.x86_64.rpm

yields 404 error when trying to download.

Thanks,
Guy

On 9/1/2014 4:24 PM, Damian Maguire wrote:
Hey Guy, 

For running the examples, the quick start guide from the wiki (http://wiki.openmama.org/index.php/Quick_start_guide) which you mention below should provide enough information to get up and running with the core example applications and the QPID bridge. At present the capturereplay application only works on Linux however (though I'm currently working on resolving this issue). These tools have been fairly extensively tested on Linux with QPID, and provided the core test framework when we were developing the bridge, but let us know if you see any issues.

Regarding the build problems, I'll need to look into the Windows ones a bit further in order to understand what's happening. Can you fire across the complete scons.log file? That should make it a bit clearer what exactly is going wrong. 

Regarding the Linux issue, what distribution are you running? The issue you're seeing is because the qpid-proton dependency cannot be met by Yum. Typically Yum will search through available repositories for those dependencies, so if it hasn't found qpid-proton it may not be available in your repositories. If you're on Centos or RHEL, you'll need to follow the instructions for setting up the EPEL repository at the bottom of the Install OpenMAMA (http://wiki.openmama.org/index.php/Quick_start_guide#Install_OpenMAMA) section of the quick start guide.

Thanks, 

Damian

From: Guy <guy.tal@...>
Date: Thursday, January 9, 2014 12:00 PM
To: "openmama-dev@..." <openmama-dev@...>
Subject: [Openmama-dev] OpenMAMA QPID Bridge issues


Hello,

I'm starting an evaluation of OpenMama (OpenMAMA 2.3.0 branch) over Qpid. I have some questions about what is covered and what tools are available. I have also had some problems with building, which are described below.

Once the build is complete, I will want to test running a Mama publisher and then subscribe to the data using mamalistenc and the Qpid bridge. Is there any documentation in the system showing me how to do this?

Finally I then want to try and get the OpenMama market data replay tools running over Qpid. Has this setup been tested ? Will it work ?


Windows Build problems.

I am seeing the following problems:
The errors I get from SCONS are:
  1. ERROR::   shared_dir None does not exist 
  2. scons: *** [D:\omama230\dynamic\common\c_cpp\src\c\libwombatcommonmd.dll] Error 1104

Details of the build in Windows problem are attached here. 
The command line for scons I ran is:
>scons middleware=qpid product=mama qpid_home=D:\proton blddir=d:\omama230 buildtype=dynamic verbose=yes
Where:
qpid_home=D:\proton - the proton tree is manually fixed by me and may not be correct
D:\PROTON
+---proton
¦   +---examples
¦   ¦   +---messenger
¦   ¦       +---pncompat
¦   +---include
¦       +---proton        <- has only version.h + all include folder I collected from 
|
+---Release               <- has the qpid-proton.dll and qpid-proton.lib
|                         <- do you expect the folder to be lib and lib64 (as in linux)?
|                         <- or do you expect a folder tree to be /architecture/configuration
|                         <- like x64/Release ?
+---share
    +---java
    +---proton-0.6


Linux Build Problems

In a clean Linux workstation I tried to follow the instructions I found in http://wiki.openmama.org/index.php/Quick_start_guide
Running  sudo yum install openmama-2.3.0-1.el6_.x86_64.rpm yielded this result:
Error: Package: openmama-2.3.0-1.el6.x86_64 (/openmama-2.3.0-1.el6_.x86_64)
           Requires: qpid-proton
Error: Package: openmama-2.3.0-1.el6.x86_64 (/openmama-2.3.0-1.el6_.x86_64)
           Requires: libqpid-proton.so.1()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

However trying to build OpenMAMA 2.3.0 against the proton 0.25 also failed.

The only working combination was building the feature-qpid-bridge branch and building the proton 0.27 (cloned from svn).

Regards,
Guy


This message may contain confidential information and is intended for specific recipients unless explicitly noted otherwise. If you have reason to believe you are not an intended recipient of this message, please delete it and notify the sender. This message may not represent the opinion of IntercontinentalExchange Group, Inc. (ICE), NYSE Euronext or any of their subsidiaries or affiliates, and does not constitute a contract or guarantee. Unencrypted electronic mail is not secure and the recipient of this message is expected to provide safeguards from viruses and pursue alternate means of communication where privacy or a binding message is desired.

Join Openmama-dev@lists.openmama.org to automatically receive all group messages.