OpenMAMA 2.1 - configure: WARNING: unrecognized options: --with-avis


David @ Rai Technology
 


Hi Mark,
You are using the wrong option it should be ./configure --avis-path=<avis source dir>

inside configure this argument gets converted to the  --with-avis required by the other configure scripts

Regards,
David

---snip---x
    case $i in
        --avis-path=*)
            AVIS_HOME=${i#*=}
            WITH_AVIS="--with-avis=${AVIS_HOME}"
            ;;

----snip--x


Mike Schonberg <mschonberg@...>
 

Mark,

 

The current top level configure script is fairly simplistic and passes all of the configure arguments to all the lower level configure scripts. If the option is not supported by the lower level configure, it emits a warning. These are, as you mention, harmless. At some point we should make the higher level script more sophisticated. It might make sense to even use autoconf rather than a simple shell script.

 

At the moment this is fairly low priority, but we should get to it when we have time.

 

Regards,

-Mike

 

From: openmama-dev-bounces@... [mailto:openmama-dev-bounces@...] On Behalf Of Mark Spielman
Sent: Thursday, May 03, 2012 9:28 AM
To: openmama-dev@...
Subject: [Openmama-dev] OpenMAMA 2.1 - configure: WARNING: unrecognized options: --with-avis

 

I’ve cloned the OpenMAMA 2.1 release git repository.  When I try to configure the environment with --wIth-avis, the output from the configure script has a bunch of warnings of the following:

 

configure: WARNING: unrecognized options: --with-avis

 

After debugging, these seem to be benign.  Can the build environment be enhanced to remove these warnings?

 

Cheers,

Mark

 

 

Mark Spielman

Development Lead, Solace Systems Professional Services
+1-613-271-1010 x1021

mark.spielman@...

www.solacesystems.com

 

 


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.


Mark Spielman
 

I’ve cloned the OpenMAMA 2.1 release git repository.  When I try to configure the environment with --wIth-avis, the output from the configure script has a bunch of warnings of the following:

 

configure: WARNING: unrecognized options: --with-avis

 

After debugging, these seem to be benign.  Can the build environment be enhanced to remove these warnings?

 

Cheers,

Mark

 

 

Mark Spielman

Development Lead, Solace Systems Professional Services
+1-613-271-1010 x1021

mark.spielman@...

www.solacesystems.com