Re: 2.1.1.2 install problem and version compatibility question


Glenn McClements <gmcclements@...>
 

Hi Bill,
Answers below. 
  • Is OpenMama 2.x wire compatible with 1.x?  I'd like to run a Java 2.x subscriber and be able to pick up either 1.x or 2.x messages. 
Yes. The wire level protocols are defined by the middlewares and message formats that OpenMAMA supports. If you are using the the underlying libraries, e.g. Avis, then OpenMAMA will be backwards compatible. 

common/c_cpp/configure needs to be generated first by running generateBuildFiles.sh. Full build instructions are in he README file.

Glenn 

From: Bill Nokes <bill.nokes@...>
Date: Mon, 9 Jul 2012 16:09:56 +0100
To: "openmama-users@..." <openmama-users@...>
Subject: [Openmama-users] 2.1.1.2 install problem and version compatibility question

Hi,

I've just picked up OpenMama 2.x and I've a few questions if I may (I tried #openmama, but all's quiet there)...

  • Is OpenMama 2.x wire compatible with 1.x?  I'd like to run a Java 2.x subscriber and be able to pick up either 1.x or 2.x messages. 

Regards,

Bill



--
16 St Martin’s Le Grand
London
EC1A 4EN
United Kingdom

+44 (0) 20 3239 8137



Please consider the environment before printing this e-mail.

This e-mail may contain confidential and/or privileged information. If you are not the intended recipient or have received this e-mail in error, please advise the sender immediately by reply e-mail and delete this message and any attachments without retaining a copy.

Any unauthorised copying, disclosure or distribution of the material in this e-mail is strictly forbidden.

Join Openmama-users@lists.openmama.org to automatically receive all group messages.