Re: missing lib mamamwmimpl

Jacobraj Benet <JBenet@...>

Hi Damian,

I would recommend that you build the mama and the bridge shared object from the source code to your specific operating system and then make sure to export the LD_LIBRARY_PATH to the location of the shared object folder.


From: openmama-users-bounces@... [openmama-users-bounces@...] on behalf of Russell Aidan (Ext. - UniCredit Business Integrated Solutions) [aidan.russell.extern@...]
Sent: Thursday, July 12, 2012 7:24 AM
To: 'Damian Maguire'
Cc: openmama-users@...
Subject: Re: [Openmama-users] missing lib mamamwmimpl

Hi Damian,
Thanks for the response. I'm just getting up-to-speed on OpenMAMA. I tried the test program as supplied, I think this is looking for the wombat bridge. I'm not sure yet which bridge would be used, though we are looking at the NYSE SuperFeed.
I tried the test program for the avis bridge but also fails in locating the libmamaavisimpl. I found this lib in the bin download, but not the src download. However the bin download is Linux 64-bit, and I use 32-bit Linux.
So I would need to locate or build the libmamaavisimpl for 32-bit. Could you suggest how to proceed ?

From: Damian Maguire [mailto:dmagdrums@...]
Sent: Thursday, July 12, 2012 2:06 PM
To: Russell Aidan (Ext. - UniCredit Business Integrated Solutions)
Cc: openmama-users@...
Subject: Re: [Openmama-users] missing lib mamamwmimpl

Hi Aidan, 

Which middleware are you attempting to make use of here? The NYSE Enterprise Edition will support LBM, Tibrv and WMW, but OpenMAMA presently only supports the Avis bridge out of the box (unless you've built a bridge yourself). "mwm" isn't something I'm familiar with. 

Can you try running the same command, but switching the value of the -m parameter to "-m avis", then checking the results?



On 12 July 2012 12:12, Russell Aidan (Ext. - UniCredit Business Integrated Solutions) <aidan.russell.extern@...> wrote:
I downloaded the OpenMAMA-2.1 source, installed and built the source on Linux (32 bit); I tried the following test program, but with the following error:
bash-3.2$ mamapublisherc -tport openmama_pub -m mwm
Starting Publisher with:
   topic:              MAMA_TOPIC
   inbound topic:      MAMA_INBOUND_TOPIC
   interval            0.500000
   transport:          openmama_pub
2012-07-12 12:03:08: mama_loadBridge(): Invalid middleware [mwm]
2012-07-12 12:03:08: mama_loadmamaPayload(): Could not open middleware bridge library [mamamwmimpl] [ cannot open shared object file: No such file or directory]
Error loading bridge: NO_BRIDGE_IMPL
How do I download or build the mamamwmimpl lib ?
Aidan Russell
Quoting Systems Development
0049 89 378 12843

Openmama-users mailing list

Please consider the environment before printing this email.

Visit our website at
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.

Join to automatically receive all group messages.