Topics

installation with AVIS


John Gray <john.gray@...>
 

Hello

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

avis error code=10107, error msg=Transport endpoint is not connected

command line:
mamapublisherc -m avis -tport pub

Avis tests for secure_sender and secure_receiver seem to work fine.

What needs done to correct this?

Thanks
John


Jacobraj Benet <JBenet@...>
 

Hi John,

If possible can you run the mamapublicherc in verbose mode –v –v –v –v and send over the verbose output.

Also please provide us with your mama.properites.

Thanks,
Jacob

From: John Gray <john.gray@...>
To: "openmama-users@..." <openmama-users@...>
Subject: [Openmama-users] installation with AVIS

Hello

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

avis error code=10107, error msg=Transport endpoint is not connected

command line:
mamapublisherc -m avis -tport pub

Avis tests for secure_sender and secure_receiver seem to work fine.

What needs done to correct this?

Thanks
John


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.


John Gray <john.gray@...>
 

Hi Jacob - see output below
mama.properties attached (assumed it would use the default localhost as the transport setting).  This is as downloaded from openmama site.

Thanks
John

john@john-laptop:~/openmama/OpenMAMA-2.1/bin$ ./mamapublisherc -m avis -s MAMA_INBOUND_TOPIC -tport pub -v -v -v -v
Starting Publisher with:
   topic:              MAMA_INBOUND_TOPIC
   inbound topic:      MAMA_INBOUND_TOPIC
   interval            0.500000
   transport:          pub
2012-05-29 04:58:27: (d2fa9700) : mama_loadBridge(): Sucessfully loaded avis bridge from library [mamaavisimpl]
2012-05-29 04:58:27: (d2fa9700) : avisBridge_open(): Entering.
2012-05-29 04:58:27: (d2fa9700) : Using path specified in WOMBAT_PATH
2012-05-29 04:58:27: (d2fa9700) : Using default properties file mama.properties
2012-05-29 04:58:27: (d2fa9700) : Attempting to load MAMA properties from /home/john/openmama/OpenMAMA-2.1/examples/mama/c
2012-05-29 04:58:27: (d2fa9700) : avisBridge_open(): Successfully created Avis queue
2012-05-29 04:58:27: (d2fa9700) :
********************************************************************************
Warning: This is a developer release and has only undergone basic sanity checks.
It is for testing only and should not be used in a production environment
**********************************************************************************
2012-05-29 04:58:27: (d2fa9700) : Using path specified in WOMBAT_PATH
2012-05-29 04:58:27: (d2fa9700) : Using default properties file mama.properties
2012-05-29 04:58:27: (d2fa9700) : Attempting to load MAMA properties from /home/john/openmama/OpenMAMA-2.1/examples/mama/c
2012-05-29 04:58:27: (d2fa9700) : mama_loadPayloadBridge(): Sucessfully loaded avismsg payload bridge from library [mamaavismsgimpl]
2012-05-29 04:58:27: (d2fa9700) : mama 6.0.0rc19 (Unable to get version number) (not entitled)
2012-05-29 04:58:27: (d2fa9700) :
********************************************************************************
Note: This build of the MAMA API is not enforcing entitlement checks.
Please see the Licensing file for details
**********************************************************************************
2012-05-29 04:58:27: (d2fa9700) : Entering mamaTransport_create for transport (0x1756850) with name pub
2012-05-29 04:58:27: (d2fa9700) : Creating transport: [pub]
2012-05-29 04:58:27: (d2fa9700) : Number of load balanced sub transports defined: [0]
2012-05-29 04:58:27: (d2fa9700) : Not using load balancing
2012-05-29 04:58:27: (d2fa9700) : initializing Avis transport: pub
2012-05-29 04:58:27: (d2fa9700) : open failed for url: pub
2012-05-29 04:58:27: (d2fa9700) : avis error code=10107, error msg=Transport endpoint is not connected
Error creating transport: STATUS_PLATFORM
john@john-laptop:~/openmama/OpenMAMA-2.1/bin$ ^C



On 29 May 2012 15:50, Jacobraj Benet <JBenet@...> wrote:
Hi John,

If possible can you run the mamapublicherc in verbose mode –v –v –v –v and send over the verbose output.

Also please provide us with your mama.properites.

Thanks,
Jacob

From: John Gray <john.gray@...>
To: "openmama-users@..." <openmama-users@...>
Subject: [Openmama-users] installation with AVIS

Hello

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

avis error code=10107, error msg=Transport endpoint is not connected

command line:
mamapublisherc -m avis -tport pub

Avis tests for secure_sender and secure_receiver seem to work fine.

What needs done to correct this?

Thanks
John


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.



Mike Schonberg <mschonberg@...>
 

Is the avis daemon running?

 

Regards,

-Mike

 

From: openmama-users-bounces@... [mailto:openmama-users-bounces@...] On Behalf Of John Gray
Sent: Monday, May 28, 2012 12:50 PM
To: openmama-users@...
Subject: [Openmama-users] installation with AVIS

 

Hello

 

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

 

avis error code=10107, error msg=Transport endpoint is not connected

 

command line:

mamapublisherc -m avis -tport pub

 

Avis tests for secure_sender and secure_receiver seem to work fine.

 

What needs done to correct this?

 

Thanks

John


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.


Jacobraj Benet <JBenet@...>
 

Thanks John,

For the mamapublisherc to work, you would need to run the avis daemon running on your local/remote machine.

Then you would need point the avis transport to the ipaddress of where you have the avis daemon is running 

For example 

My mama.properties.
mama.avis.transport.avis_tport.url=elvin://0.0.0.0

My command line
Mamapublisherc –m avis –tort avis_tport

My Avis Dameon
I have my avis daemon running on localhost.

Thanks,
Jacob

From: John Gray <john.gray@...>
To: Jacobraj Benet <jbenet@...>
Cc: "openmama-users@..." <openmama-users@...>
Subject: Re: [Openmama-users] installation with AVIS

Hi Jacob - see output below
mama.properties attached (assumed it would use the default localhost as the transport setting).  This is as downloaded from openmama site.

Thanks
John

john@john-laptop:~/openmama/OpenMAMA-2.1/bin$ ./mamapublisherc -m avis -s MAMA_INBOUND_TOPIC -tport pub -v -v -v -v
Starting Publisher with:
   topic:              MAMA_INBOUND_TOPIC
   inbound topic:      MAMA_INBOUND_TOPIC
   interval            0.500000
   transport:          pub
2012-05-29 04:58:27: (d2fa9700) : mama_loadBridge(): Sucessfully loaded avis bridge from library [mamaavisimpl]
2012-05-29 04:58:27: (d2fa9700) : avisBridge_open(): Entering.
2012-05-29 04:58:27: (d2fa9700) : Using path specified in WOMBAT_PATH
2012-05-29 04:58:27: (d2fa9700) : Using default properties file mama.properties
2012-05-29 04:58:27: (d2fa9700) : Attempting to load MAMA properties from /home/john/openmama/OpenMAMA-2.1/examples/mama/c
2012-05-29 04:58:27: (d2fa9700) : avisBridge_open(): Successfully created Avis queue
2012-05-29 04:58:27: (d2fa9700) :
********************************************************************************
Warning: This is a developer release and has only undergone basic sanity checks.
It is for testing only and should not be used in a production environment
**********************************************************************************
2012-05-29 04:58:27: (d2fa9700) : Using path specified in WOMBAT_PATH
2012-05-29 04:58:27: (d2fa9700) : Using default properties file mama.properties
2012-05-29 04:58:27: (d2fa9700) : Attempting to load MAMA properties from /home/john/openmama/OpenMAMA-2.1/examples/mama/c
2012-05-29 04:58:27: (d2fa9700) : mama_loadPayloadBridge(): Sucessfully loaded avismsg payload bridge from library [mamaavismsgimpl]
2012-05-29 04:58:27: (d2fa9700) : mama 6.0.0rc19 (Unable to get version number) (not entitled)
2012-05-29 04:58:27: (d2fa9700) :
********************************************************************************
Note: This build of the MAMA API is not enforcing entitlement checks.
Please see the Licensing file for details
**********************************************************************************
2012-05-29 04:58:27: (d2fa9700) : Entering mamaTransport_create for transport (0x1756850) with name pub
2012-05-29 04:58:27: (d2fa9700) : Creating transport: [pub]
2012-05-29 04:58:27: (d2fa9700) : Number of load balanced sub transports defined: [0]
2012-05-29 04:58:27: (d2fa9700) : Not using load balancing
2012-05-29 04:58:27: (d2fa9700) : initializing Avis transport: pub
2012-05-29 04:58:27: (d2fa9700) : open failed for url: pub
2012-05-29 04:58:27: (d2fa9700) : avis error code=10107, error msg=Transport endpoint is not connected
Error creating transport: STATUS_PLATFORM
john@john-laptop:~/openmama/OpenMAMA-2.1/bin$ ^C



On 29 May 2012 15:50, Jacobraj Benet <JBenet@...> wrote:
Hi John,

If possible can you run the mamapublicherc in verbose mode –v –v –v –v and send over the verbose output.

Also please provide us with your mama.properites.

Thanks,
Jacob

From: John Gray <john.gray@...>
To: "openmama-users@..." <openmama-users@...>
Subject: [Openmama-users] installation with AVIS

Hello

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

avis error code=10107, error msg=Transport endpoint is not connected

command line:
mamapublisherc -m avis -tport pub

Avis tests for secure_sender and secure_receiver seem to work fine.

What needs done to correct this?

Thanks
John


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.



Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.


John Gray <john.gray@...>
 

no - how do I start the avis daemon on the localhost?


On 29 May 2012 16:10, Mike Schonberg <mschonberg@...> wrote:

Is the avis daemon running?

 

Regards,

-Mike

 

From: openmama-users-bounces@... [mailto:openmama-users-bounces@...] On Behalf Of John Gray
Sent: Monday, May 28, 2012 12:50 PM
To: openmama-users@...


Subject: [Openmama-users] installation with AVIS

 

Hello

 

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

 

avis error code=10107, error msg=Transport endpoint is not connected

 

command line:

mamapublisherc -m avis -tport pub

 

Avis tests for secure_sender and secure_receiver seem to work fine.

 

What needs done to correct this?

 

Thanks

John


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.



Mike Schonberg <mschonberg@...>
 

avisd –v.

 

-Mike

 

From: John Gray [mailto:john.gray@...]
Sent: Tuesday, May 29, 2012 8:32 AM
To: Mike Schonberg
Cc: openmama-users@...
Subject: Re: [Openmama-users] installation with AVIS

 

no - how do I start the avis daemon on the localhost?

On 29 May 2012 16:10, Mike Schonberg <mschonberg@...> wrote:

Is the avis daemon running?

 

Regards,

-Mike

 

From: openmama-users-bounces@... [mailto:openmama-users-bounces@...] On Behalf Of John Gray
Sent: Monday, May 28, 2012 12:50 PM
To: openmama-users@...


Subject: [Openmama-users] installation with AVIS

 

Hello

 

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

 

avis error code=10107, error msg=Transport endpoint is not connected

 

command line:

mamapublisherc -m avis -tport pub

 

Avis tests for secure_sender and secure_receiver seem to work fine.

 

What needs done to correct this?

 

Thanks

John


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.

 


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.


John Gray <john.gray@...>
 

Hey - thats fixed it - thanks!

Maybe need to add that to the mama README file.  avisd is placed in the /usr/local/sbin folder.
Also, was able to run publisher:

./mamapublisherc -m avis -tport avis  and worked fine.

j


On 29 May 2012 16:37, Mike Schonberg <mschonberg@...> wrote:

avisd –v.

 

-Mike

 

From: John Gray [mailto:john.gray@...]
Sent: Tuesday, May 29, 2012 8:32 AM
To: Mike Schonberg
Cc: openmama-users@...


Subject: Re: [Openmama-users] installation with AVIS

 

no - how do I start the avis daemon on the localhost?

On 29 May 2012 16:10, Mike Schonberg <mschonberg@...> wrote:

Is the avis daemon running?

 

Regards,

-Mike

 

From: openmama-users-bounces@... [mailto:openmama-users-bounces@...] On Behalf Of John Gray
Sent: Monday, May 28, 2012 12:50 PM
To: openmama-users@...


Subject: [Openmama-users] installation with AVIS

 

Hello

 

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

 

avis error code=10107, error msg=Transport endpoint is not connected

 

command line:

mamapublisherc -m avis -tport pub

 

Avis tests for secure_sender and secure_receiver seem to work fine.

 

What needs done to correct this?

 

Thanks

John


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.

 


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.



John Gray <john.gray@...>
 

Hey Guys

I have tried building the openmama examples - but can't get this to happen.

The ./configure --with-avis=/usr/local comes back with unknown parameter --with-avis

Also, the /opt/openmama files get updated from the build - but the files in openmama-2.1/bin and openmama-2.1/lib don't change from the original dates.

Am I doing something wrong - I would like to able to edit the examples for running tests.

thanks
John


On 29 May 2012 16:49, John Gray <john.gray@...> wrote:
Hey - thats fixed it - thanks!

Maybe need to add that to the mama README file.  avisd is placed in the /usr/local/sbin folder.
Also, was able to run publisher

./mamapublisherc -m avis -tport avis  and worked fine.

j


On 29 May 2012 16:37, Mike Schonberg <mschonberg@...> wrote:

avisd –v.

 

-Mike

 

From: John Gray [mailto:john.gray@...]
Sent: Tuesday, May 29, 2012 8:32 AM
To: Mike Schonberg
Cc: openmama-users@...


Subject: Re: [Openmama-users] installation with AVIS

 

no - how do I start the avis daemon on the localhost?

On 29 May 2012 16:10, Mike Schonberg <mschonberg@...> wrote:

Is the avis daemon running?

 

Regards,

-Mike

 

From: openmama-users-bounces@... [mailto:openmama-users-bounces@...] On Behalf Of John Gray
Sent: Monday, May 28, 2012 12:50 PM
To: openmama-users@...


Subject: [Openmama-users] installation with AVIS

 

Hello

 

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

 

avis error code=10107, error msg=Transport endpoint is not connected

 

command line:

mamapublisherc -m avis -tport pub

 

Avis tests for secure_sender and secure_receiver seem to work fine.

 

What needs done to correct this?

 

Thanks

John


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.

 


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.




Jacobraj Benet <JBenet@...>
 

Hi John,

The configure script in openmama accepts —avis-path instead of —with-avis, so you could try the following.

./configure —avis-path=/usr/local 

Also if you would like the openmama-2.1 to be updated, then you would need pass the correct location as part of the prefix

So I would recommend using the following configure arguments.

./configure —avis-path=/usr/local —prefix=openmama-2.1

Thanks,
Jacob

From: John Gray <john.gray@...>
Date: Friday, June 1, 2012 2:10 PM
To: Michael Schonberg <mschonberg@...>
Cc: "openmama-users@..." <openmama-users@...>
Subject: Re: [Openmama-users] installation with AVIS

Hey Guys

I have tried building the openmama examples - but can't get this to happen.

The ./configure --with-avis=/usr/local comes back with unknown parameter --with-avis

Also, the /opt/openmama files get updated from the build - but the files in openmama-2.1/bin and openmama-2.1/lib don't change from the original dates.

Am I doing something wrong - I would like to able to edit the examples for running tests.

thanks
John

On 29 May 2012 16:49, John Gray <john.gray@...> wrote:
Hey - thats fixed it - thanks!

Maybe need to add that to the mama README file.  avisd is placed in the /usr/local/sbin folder.
Also, was able to run publisher

./mamapublisherc -m avis -tport avis  and worked fine.

j


On 29 May 2012 16:37, Mike Schonberg <mschonberg@...> wrote:

avisd –v.

 

-Mike

 

From: John Gray [mailto:john.gray@...]
Sent: Tuesday, May 29, 2012 8:32 AM
To: Mike Schonberg
Cc: openmama-users@...


Subject: Re: [Openmama-users] installation with AVIS

 

no - how do I start the avis daemon on the localhost?

On 29 May 2012 16:10, Mike Schonberg <mschonberg@...> wrote:

Is the avis daemon running?

 

Regards,

-Mike

 

From:openmama-users-bounces@... [mailto:openmama-users-bounces@...] On Behalf Of John Gray
Sent: Monday, May 28, 2012 12:50 PM
To: openmama-users@...


Subject: [Openmama-users] installation with AVIS

 

Hello

 

I have installed openmama and avis from the websites, but when trying to run mamapublisherc I get the following error....

 

avis error code=10107, error msg=Transport endpoint is not connected

 

command line:

mamapublisherc -m avis -tport pub

 

Avis tests for secure_sender and secure_receiver seem to work fine.

 

What needs done to correct this?

 

Thanks

John


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.

 


Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.




Please consider the environment before printing this email.

Visit our website at http://www.nyse.com
*****************************************************************************
Note: The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure. If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system. Thank you. NYSE Euronext.


John Gray <john.gray@...>
 

Apologies for resorting back again - this is probably more UNIX than mama!

I can see the make files being constructed, but the examples are still not being built - and the make seems to stop before getting to the examples directory,
At the end of the make file i get the following error:

libtool: link: gcc -shared  -fPIC -DPIC  .libs/bridge.o .libs/clientmanageresponder.o .libs/datetime.o .libs/dictionary.o .libs/dqstrategy.o .libs/error.o .libs/fielddesc.o .libs/imagerequest.o .libs/listenermsgcallback.o .libs/log.o .libs/mama.o .libs/mamaStrUtils.o .libs/marketdata.o .libs/middleware.o .libs/msg.o .libs/msgfield.o .libs/msgqualifier.o .libs/msgstatus.o .libs/msgtype.o .libs/msgutils.o .libs/publisher.o .libs/dqpublisher.o .libs/dqpublishermanager.o .libs/inbox.o .libs/quality.o .libs/reservedfields.o .libs/senderId.o .libs/servicelevel.o .libs/queue.o .libs/io.o .libs/price.o .libs/priceimpl.o .libs/refreshtransport.o .libs/timer.o .libs/timezone.o .libs/source.o .libs/sourceman.o .libs/status.o .libs/stat.o .libs/statscollector.o .libs/statfields.o .libs/statsgenerator.o .libs/subscmsgtype.o .libs/subscription.o .libs/subscriptiontype.o .libs/statslogger.o .libs/statsloggerfields.o .libs/symbollist.o .libs/ft.o .libs/symbollistmember.o .libs/symbolmapfile.o .libs/syncresponder.o .libs/throttle.o .libs/transport.o .libs/fileutils.o .libs/playbackFileParser.o .libs/playbackpublisher.o .libs/playbackcapture.o .libs/connection.o .libs/serverconnection.o .libs/manager.o .libs/version.o   -L/usr/local/lib -L./../../../../common/c_cpp/src/c -lnsl -lrt /home/john/openmama/OpenMAMA-2.1/common/c_cpp/src/c/.libs/libwombatcommon.a -ldl -luuid  -O2   -Wl,-soname -Wl,libmama.so.0 -o .libs/libmama.so.0.0.0

/usr/bin/ld: cannot find -luuid
collect2: ld returned 1 exit status

I have checked the libuuid file exists and have added the /lib to the LD_LIBRARY_PATH to try to get around this - but no luck.

May I beg your assistance?

Thanks
j


On 4 June 2012 23:00, Mike Schonberg <mschonberg@...> wrote:
John,

Based on your make logs, it looks like you don't have ant and java (Sun JDK 6) installed. I plan on changing the default build to build C/C++ only as many users do not require Java. In the mean time you can build OpenMAMA C/C++ with "make mama-install" and OpenMAMDA C/C++ with "make mamda-install". The OpenMAMDA build requires a couple of build patches that I submitted to the openmama-dev list. I will be pushing these patches to git in the next day or so.

Regards,
-Mike

> -----Original Message-----
> From: John Gray [mailto:john.gray@...]
> Sent: Saturday, June 02, 2012 6:17 AM
> To: Jacobraj Benet
> Cc: Mike Schonberg; openmama-users@...
> Subject: Re: [Openmama-users] installation with AVIS
>
> Hi
>
> Still having no luck getting the source to build to example execs and binary.
> I have attached the config logs and the output from the make pushed to a file.
>
> I used the commands:
>
> ./configure --avis-path=/usr/local --prefix=/home/john/openmama/Openmama-2.1
> make
>
> Any assistance welcome.
>
> Thanks
> John
>
>
> On 1 June 2012 20:37, Jacobraj Benet <JBenet@...> wrote:
>
>
>       Hi John,
>
>       The configure script in openmama accepts -avis-path instead of -with-
> avis, so you could try the following.
>
>       ./configure -avis-path=/usr/local
>
>       Also if you would like the openmama-2.1 to be updated, then you would
> need pass the correct location as part of the prefix
>
>       So I would recommend using the following configure arguments.
>
>       ./configure -avis-path=/usr/local -prefix=openmama-2.1
>
>       Thanks,
>       Jacob
>
>
>       From: John Gray <john.gray@...>
>       Date: Friday, June 1, 2012 2:10 PM
>       To: Michael Schonberg <mschonberg@...>
>       Cc: "openmama-users@..." <openmama-
> users@...>
>
>       Subject: Re: [Openmama-users] installation with AVIS
>
>
>       Hey Guys
>
>       I have tried building the openmama examples - but can't get this to
> happen.
>
>       The ./configure --with-avis=/usr/local comes back with unknown parameter
> --with-avis
>
>       Also, the /opt/openmama files get updated from the build - but the files
> in openmama-2.1/bin and openmama-2.1/lib don't change from the original dates.
>
>       Am I doing something wrong - I would like to able to edit the examples
> for running tests.
>
>       thanks
>       John
>
>
>       On 29 May 2012 16:49, John Gray <john.gray@...> wrote:
>
>
>               Hey - thats fixed it - thanks!
>
>               Maybe need to add that to the mama README file.  avisd is placed
> in the /usr/local/sbin folder.
>               Also, was able to run publisher
>
>               ./mamapublisherc -m avis -tport avis  and worked fine.
>
>
>               j
>
>
>               On 29 May 2012 16:37, Mike Schonberg <mschonberg@...> wrote:
>
>
>                       avisd -v.
>
>
>
>                       -Mike
>
>
>
>                       From: John Gray [mailto:john.gray@...]
>                       Sent: Tuesday, May 29, 2012 8:32 AM
>                       To: Mike Schonberg
>                       Cc: openmama-users@...
>
>
>                       Subject: Re: [Openmama-users] installation with AVIS
>
>
>
>
>
>                       no - how do I start the avis daemon on the localhost?
>
>                       On 29 May 2012 16:10, Mike Schonberg <mschonberg@...>
> wrote:
>
>                       Is the avis daemon running?
>
>
>
>                       Regards,
>
>                       -Mike
>
>
>
>                       From:openmama-users-bounces@...
> [mailto:openmama-users-bounces@...] On Behalf Of John Gray
>                       Sent: Monday, May 28, 2012 12:50 PM
>                       To: openmama-users@...
>
>
>                       Subject: [Openmama-users] installation with AVIS
>
>
>
>                       Hello
>
>
>
>                       I have installed openmama and avis from the websites, but
> when trying to run mamapublisherc I get the following error....
>
>
>
>                       avis error code=10107, error msg=Transport endpoint is not
> connected
>
>
>
>                       command line:
>
>                       mamapublisherc -m avis -tport pub
>
>
>
>                       Avis tests for secure_sender and secure_receiver seem to
> work fine.
>
>
>
>                       What needs done to correct this?
>
>
>
>                       Thanks
>
>                       John
>
> ________________________________
>
>                       Please consider the environment before printing this email.
>
>                       Visit our website at http://www.nyse.com
>
>       ************************************************************************
> *****
>                       Note: The information contained in this message and any
> attachment to it is privileged, confidential and protected from disclosure. If
> the reader of this message is not the intended recipient, or an employee or
> agent responsible for delivering this message to the intended recipient, you
> are hereby notified that any dissemination, distribution or copying of this
> communication is strictly prohibited. If you have received this communication
> in error, please notify the sender immediately by replying to the message, and
> please delete it from your system. Thank you. NYSE Euronext.
>
>
>
>
>
> ________________________________
>
>
>
>                       Please consider the environment before printing this email.
>
>                       Visit our website at http://www.nyse.com
>
>       ************************************************************************
> *****
>                       Note: The information contained in this message and any
> attachment to it is privileged, confidential and protected from disclosure. If
> the reader of this message is not the intended recipient, or an employee or
> agent responsible for delivering this message to the intended recipient, you
> are hereby notified that any dissemination, distribution or copying of this
> communication is strictly prohibited. If you have received this communication
> in error, please notify the sender immediately by replying to the message, and
> please delete it from your system. Thank you. NYSE Euronext.
>
>
>
>
>
> ________________________________
>
>
>
>       Please consider the environment before printing this email.
>
>       Visit our website at http://www.nyse.com
>       ************************************************************************
> *****
>       Note: The information contained in this message and any attachment to it
> is privileged, confidential and protected from disclosure. If the reader of
> this message is not the intended recipient, or an employee or agent
> responsible for delivering this message to the intended recipient, you are
> hereby notified that any dissemination, distribution or copying of this
> communication is strictly prohibited. If you have received this communication
> in error, please notify the sender immediately by replying to the message, and
> please delete it from your system. Thank you. NYSE Euronext.
>

Please consider the environment before printing this email.

Visit our website at http://www.nyse.com

****************************************************

Note:  The information contained in this message and any attachment to it is privileged, confidential and protected from disclosure.  If the reader of this message is not the intended recipient, or an employee or agent responsible for delivering this message to the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited.  If you have received this communication in error, please notify the sender immediately by replying to the message, and please delete it from your system.  Thank you.  NYSE Euronext.